Nginx配置指北之gzip

浏览: 153 发布日期: 2017-08-10 分类: nginx

无论是前端还是后端,在部署项目时,时常免不了用到Nginx,小项目也时常做个反向代理啥的。今天就简单直接,聊一下其中的一个点——gzip。如有错误,欢迎指正。

一般服务器端常用的是 UbuntuCentOSLinux 等。自己若没有服务器,可在本地把玩一下。

mac 安装

mac下可直接用brew安装,若未安装brew可先行安装

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
brew install nginx

默认配置

安装完成后会看到命令行含有以下信息,可以看到 nginx.conf所在路径,这正是我们要找的配置文件。同时含有端口信息,当启动Nginx时,可以直接访问http://localhost:8080,当看到下图所示页面,即安装启动成功。

docroot: /usr/local/var/www
default config: /usr/local/etc/nginx/nginx.conf
port:8080

几个常用命令

启动:nginx
重新热启动:nginx -s reload
关闭:nginx -s stop
测试语法:nginx -t

gizp配置:

gzip 相关配置可放在 http{}server{}location{} 层级,若不同层级有重复设置优先级为 location{} > server{} > http{}

  1. 开启 gzip压缩

    gzip on;
  2. gzip http 版本

    gzip_http_version 1.0;
  3. 禁止IE6进行gzip压缩(当然现在已经基本没有人使用IE6了)

    gzip_disable "MSIE [1-6]";
  4. 压缩级别(1~9,一般为平衡文件大小和CPU使用,5是常用值,当然跟实际机器的情况有关)

    gzip_comp_level 5;
  5. 最小压缩临界值(默认的是20字节)

    gzip_min_length 20;
  6. 压缩通过代理链接的客户端数据

    gzip_proxied any;
  7. 采用http协议版本 默认是1.1 ,对于1.0的请求不会压缩,如果设置成1.0,表示http1.0以上 的版本都会压缩。(如果使用了proxy_pass 进行反向代理,那么nginx和后端的 upstream server之间默认是用 HTTP/1.0协议通信的。)

    gzip_http_version 1.0;
  8. 代理缓存压缩和原始版本资源,避免客户端因Accept-Encoding不支持gzip而发生错误的现象(现在一般都采用gzip)

    gzip_vary on;
  9. 压缩文件类型(默认总是压缩 text/html类型,其中特别说明的是application/javascript和text/javascript最好都加上,若页面script标签的type不同则有可能发生部分js文件不会压缩,默认type为application/javascript)

    gzip_types application/atom+xml application/javascript application/json application/rss+xml application/vnd.ms-fontobject application/x-font-ttf application/x-web-app-manifest+json application/xhtml+xml application/xml font/opentype image/svg+xml image/x-icon text/css text/plain text/javascript text/x-component;
  10. 如果有已经压缩的(.gz)或者提供静态文件服务,可以设置为on。如果不是这样,最好设置为off,因为这会造成额外的I/O开销。一个比较好的处理方式是放在location{}或server{}级别单独处理。

    gzip_static on;
  11. 压缩结果数据流存储所用空间,下面表示以8k为单位,按照原始数据大小以8k为单位的16倍申请内存。默认值是申请跟原始数据相同大小的内存空间去存储gzip压缩结果。

    gzip_buffers 16 8k;
返回顶部