apt-get 安装失败问题

浏览: 228 发布日期: 2016-08-19 分类: ubuntu

今天在安装一个包时出现错误

sudo apt-get install libmapnik

从提示看不出来问题原因

于是就按照提示apt-get -f install了一把,还是报错,应该是安装nodejs-dev时会覆盖nodejs-legacy的某个包,导致安装失败

百度了半天没搞明白nodejs-legacy和nodejs的区别,于是强制安装了一把,

sudo dpkg -i --force-overwrite  /var/cache/apt/archives/nodejs_0.10.28-1chl1~trusty1_amd64.deb

仍然失败,于是安装了一把rlwrap,安装成功了

然后再来安装就成功了

sudo apt-get install libmapnik

dpkg -i --force-overwrite、apt-get -f install 是解决安装冲突问题的两大利器

返回顶部